tcl-websh-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rani Ahmed <rani...@gmail.com>
Subject Fwd: Compiling and Building error of websh: ../websh-3.6.0b5/src/unix/../generic/tclAppInit.c:173: undefined reference to `Websh_Init'
Date Fri, 03 Jan 2014 14:22:29 GMT
---------- Forwarded message ----------
From: Rani Ahmed <ranixlb@gmail.com>
Date: Fri, Jan 3, 2014 at 12:25 PM
Subject: Compiling and Building error of websh:
../websh-3.6.0b5/src/unix/../generic/tclAppInit.c:173: undefined reference
to `Websh_Init'
To: websh-user@tcl.apache.org


I am using debian wheezy 7.3 updated with  debian backports repository.
system is 64bit.
I use ActiveState Tcl 8.6 (latest on at this time of this writing it's
"ActiveTcl8.6.1.0.297577-linux-x86_64-threaded"
I have Apache 2
I have installed debian package "libapr1-dev" installed . its version is
1.4.6-3+deb7u1 to use in building.websh.
I have installed debian package "apache2-threaded-dev" , version
2.2.22-13,  to use with building websh.

this is how I configured it:

./configure --with-tcl=/opt/ActiveTcl-8.6/lib/
--with-tclinclude=/opt/ActiveTcl-8.6/include/ --enable-threads
--with-aprinclude=/usr/include/apr-1.0/

and finally after the command "make" i finally get:

cc  tclAppInit.o libwebsh3.6.0b5.so \
    -L/opt/ActiveTcl-8.6/lib -ltcl8.6 -L/opt/ActiveTcl-8.6/lib -ltclstub8.6
-ldl -lz  -lpthread -lieee -lm -Wl,--export-dynamic  \
    -o websh3.6.0b5
tclAppInit.o: In function `Tcl_AppInit':
/home/oracle/Downloads/websh-3.6.0b5/src/unix/../generic/tclAppInit.c:173:
undefined reference to `Websh_Init'
collect2: error: ld returned 1 exit status
make: *** [websh3.6.0b5] Error 1

Tell me please how this should patched or fixed. Thanks in advance.

=====
Rani Ahmad.

Mime
View raw message