tez-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Hitesh Shah <hit...@apache.org>
Subject Re: [DISCUSS] What versions of hadoop should we support?
Date Wed, 10 Dec 2014 06:17:31 GMT
Thanks for the info Johannes. 

Given the absence of timeline and therefore no historical data, it is unlikely that a tez
history UI will be supported against 2.2.
That said, there is probably going to be future work to build a UI into the application master
itself for tracking a running DAG which likely should not be timeline dependent. 

— HItesh


On Dec 9, 2014, at 8:29 PM, Johannes Zillmann <jzillmann@googlemail.com> wrote:

> We have a wide range of customers… so basically all of them ;)
> Anyhow would be good to have at least clear announcements like for 0.5 there is 2.2 minimum,
for 0.6 there is… etc..
> If the Hadoop UI integration could be delivered with 2.2 that would be awesome!
> 
> best
> Johannes
> 
>> On 08 Dec 2014, at 19:02, Hitesh Shah <hitesh@apache.org> wrote:
>> 
>> Thanks for the info, Douglas. We will not be dropping support for 2.4 for sure at
the moment.
>> 
>> Anyone else have any comments in this regard?
>> 
>> @Bikas/@Sid - what do we do about publishing jars for a release? We would need to
publish 2 or 3 sets?
>> 
>> thanks
>> — Hitesh
>> 
>> On Dec 4, 2014, at 12:51 PM, Moore, Douglas <Douglas.Moore@thinkbiganalytics.com>
wrote:
>> 
>>> 2.4.x and beyond for the customers we have
>>> 
>>> Sent from my iPhone
>>> 
>>>> On Dec 4, 2014, at 12:36 PM, Hitesh Shah <hitesh@apache.org> wrote:
>>>> 
>>>> Hello folks 
>>>> 
>>>> Could folks who are following these mailing lists do a raise of hands on
which versions of Hadoop you are trying to run Tez on? 
>>>> 
>>>> 1) 2.2.x
>>>> 2) 2.3.x
>>>> 3) 2.4.x
>>>> 4) 2.5.x
>>>> 5) 2.6.x
>>>> 
>>>> Given that we are building out the UI and for the large part, the History
UI ( i.e. the one which will display DAG details after an app has disappeared ) will be dependent
on YARN Timeline, the UI will not be supported for Hadoop versions 2.2.x and 2.3.x given that
they do not support Timeline. 
>>>> Likewise, ACLs support in Timeline was introduced in Hadoop 2.6.x - this
means ACLs will not be enforceable on Hadoop 2.4.x and 2.5.x 
>>>> 
>>>> Also, as part of TEZ-1696, I also propose changing the default version to
2.6.0 given that secure Timeline is only available as of 2.6.0.
>>>> 
>>>> Thoughts/concerns?
>>>> 
>>>> thanks
>>>> — Hitesh 
>>>> 
>> 
> 


Mime
View raw message