tez-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Hitesh Shah <hit...@apache.org>
Subject [DISCUSS] What versions of hadoop should we support?
Date Thu, 04 Dec 2014 19:36:41 GMT
Hello folks 

Could folks who are following these mailing lists do a raise of hands on which versions of
Hadoop you are trying to run Tez on? 

1) 2.2.x
2) 2.3.x
3) 2.4.x
4) 2.5.x
5) 2.6.x

Given that we are building out the UI and for the large part, the History UI ( i.e. the one
which will display DAG details after an app has disappeared ) will be dependent on YARN Timeline,
the UI will not be supported for Hadoop versions 2.2.x and 2.3.x given that they do not support
Timeline. 
Likewise, ACLs support in Timeline was introduced in Hadoop 2.6.x - this means ACLs will not
be enforceable on Hadoop 2.4.x and 2.5.x 

Also, as part of TEZ-1696, I also propose changing the default version to 2.6.0 given that
secure Timeline is only available as of 2.6.0.

Thoughts/concerns?

thanks
— Hitesh 


Mime
View raw message