tez-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Siddharth Seth <ss...@apache.org>
Subject Re: [DISCUSS] Move master (0.9) to use Java 8 as the minimum version
Date Thu, 11 May 2017 18:13:14 GMT
Hadoop 3 is Java 8 only. I believe older versions run on Java 8 as well. We
should be able to de-link the Hadoop version discussion from the Java 8
discussion, as long as the min Hadoop version supports java 8.

On Thu, May 11, 2017 at 10:53 AM, Hitesh Shah <hitesh@apache.org> wrote:

> How do we want to decide on what is the minimum version of hadoop that will
> be supported by master? Will that impact the java8 choice?
>
> -- Hitesh
>
> On Mon, May 8, 2017 at 10:15 AM, zhiyuan yang <sjtu.yzy@gmail.com> wrote:
>
> > I’m +1 for this. This is a must to make Tez work with Hadoop 3.0. Hadoop
> > 3.0 already use Java 8 and some dependencies shared by Tez also requires
> > Java 8 in new version, such as guava 21.0.
> >
> > Thanks!
> > Zhiyuan
> > > On May 3, 2017, at 5:57 PM, Siddharth Seth <sseth@apache.org> wrote:
> > >
> > > Java7 was EOLd about 2 years ago. Should we move master to use Java8?
> > >
> > > Thanks,
> > > Sid
> >
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message