tez-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jonathan Eagles (JIRA)" <j...@apache.org>
Subject [jira] [Created] (TEZ-3787) Remove Tez UI build and rebuild errors and warning due to yarn install and ember-truth-helpers
Date Thu, 06 Jul 2017 16:14:00 GMT
Jonathan Eagles created TEZ-3787:
------------------------------------

             Summary: Remove Tez UI build and rebuild errors and warning due to yarn install
and ember-truth-helpers
                 Key: TEZ-3787
                 URL: https://issues.apache.org/jira/browse/TEZ-3787
             Project: Apache Tez
          Issue Type: Sub-task
          Components: UI
            Reporter: Jonathan Eagles
            Assignee: Jonathan Eagles


{code:title=Tez UI Build}
[INFO] --- frontend-maven-plugin:1.2:install-node-and-yarn (install node and yarn) @ tez-ui
---
[INFO] Installing node version v5.12.0
[INFO] Unpacking ~/.m2/repository/com/github/eirslett/node/5.12.0/node-5.12.0-darwin-x64.tar.gz
into ~/tez/tez-ui/src/main/webapp/node/tmp
[INFO] Copying node binary from ~/tez/tez-ui/src/main/webapp/node/tmp/node-v5.12.0-darwin-x64/bin/node
to ~/tez/tez-ui/src/main/webapp/node/node
[INFO] Installed node locally.
[INFO] Installing Yarn version v0.21.3
[INFO] Unpacking ~/.m2/repository/com/github/eirslett/yarn/0.21.3/yarn-0.21.3./yarn-v0.21.3.tar.gz
into ~/tez/tez-ui/src/main/webapp/node/yarn
[INFO] Installed Yarn locally.
[INFO]
[INFO] --- frontend-maven-plugin:1.2:yarn (yarn install) @ tez-ui ---
[INFO] Running 'yarn install' in ~/tez/tez-ui/src/main/webapp
[INFO] yarn install v0.21.3
[INFO] [1/4] Resolving packages...
[INFO] [2/4] Fetching packages...
[ERROR] warning ember-truth-helpers@1.2.0: The engine "ember-cli-app-version" appears to be
invalid.
[INFO] [3/4] Linking dependencies...
[INFO] [4/4] Building fresh packages...
[INFO] Done in 16.29s.
{code}

{code:title=Tez UI Rebuild}
[INFO] --- frontend-maven-plugin:1.2:install-node-and-yarn (install node and yarn) @ tez-ui
---
[INFO] Node v5.12.0 is already installed.
[INFO] Yarn 0.21.3 was installed, but we need version v0.21.3
[INFO] Installing Yarn version v0.21.3
[INFO] Unpacking ~/.m2/repository/com/github/eirslett/yarn/0.21.3/yarn-0.21.3./yarn-v0.21.3.tar.gz
into ~/tez/tez-ui/src/main/webapp/node/yarn
[INFO] Installed Yarn locally.
[INFO]
[INFO] --- frontend-maven-plugin:1.2:yarn (yarn install) @ tez-ui ---
[INFO] Running 'yarn install' in ~/tez/tez-ui/src/main/webapp
[INFO] yarn install v0.21.3
[INFO] [1/4] Resolving packages...
[INFO] success Already up-to-date.
[INFO] Done in 0.75s.
{code}



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message