thrift-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mark Schmit <msch...@gmail.com>
Subject No C++ types output from Thrift compiler on Windows
Date Mon, 07 Sep 2009 05:08:32 GMT
Hey guys,
I'm new to Thrift but am looking forward to playing with it.  Unfortunately
I'm struggling to get a working Thrift compiler on Windows.  I've built
thrift.exe in Cygwin with the no-cygwin-dependency path documented on
http://wiki.apache.org/thrift/ThriftInstallationWin32, but it seems to only
half-work.  For example, when I try to generate C++ code using the tutorial
files, the compiler says this:

[ERROR:c:\development\project\foo\thrift\tutorial.thrift:123] (last
token was 'shared.SharedService')
Service "shared.SharedService" has not been defined.

The same command line works fine on Linux.  Secondly, if I try compiling
shared.thrift directly, I only see SharedService.h/cpp and
SharedService_server.skeleton.cpp, while on Linux I also see
shared_types.h/cpp.  I tried some other sample .thrift files and it seems
like I'm missing all of the thrift-file-related (as opposed to
service-related) C++ files.

I tried generating Java and Python as well.  Java seemed to work correctly,
outputting the same thing on both Linux and Windows.  Python didn't output
*anything* on Windows, while it generated appropriate files and directories
on Linux.

What's going on?  Did I build thrift.exe incorrectly?  Does something about
it not like Windows?  Have others encountered similar problems?  (Any chance
of a binary distribution of thrift.exe so I can expect the compiled binary
to do what it's supposed to?)

-Mark

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message