thrift-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Reiss <dre...@facebook.com>
Subject Re: Error in Compiling Native Thrift PHP Module
Date Wed, 14 Apr 2010 03:53:46 GMT
I think we (Facebook) have only ever built it with PHP 5.2.

Arya Goudarzi wrote:
> Hi There, 
> 
> I am trying to compile Thrift's PHP module natively: 
> 
> thrift-0.2.0/lib/php/src/ext/thrift_protocol # make 
> 
> I get the following error and I could not find an online reference to help me with this
issue: 
> 
> /root/workspace/thrift-0.2.0/lib/php/src/ext/thrift_protocol/php_thrift_protocol.cpp:378:
error: 'zend_std_get_constructor' was not declared in this scope 
> make: *** [php_thrift_protocol.lo] Error 1 
> 
> This is the php version I am using: 
> 
> [root@localhost thrift_protocol]# yum list | grep installed | grep php 
> php.x86_64 5.1.6-24.el5_4.5 installed 
> php-cli.x86_64 5.1.6-24.el5_4.5 installed 
> php-common.x86_64 5.1.6-24.el5_4.5 installed 
> php-devel.x86_64 5.1.6-24.el5_4.5 installed 
> php-mysql.x86_64 5.1.6-24.el5_4.5 installed 
> php-pdo.x86_64 5.1.6-24.el5_4.5 installed 
> php-pear.noarch 1:1.4.9-6.el5 installed 
> php-pecl-memcache.x86_64 2.2.3-1.el5_2 installed 
> 
> Could this be an environment issue? I am using CentOS 5.2. 
> 
> Any help will be greatly appreciated. 
> 
> Please advice. 
> 
> Cheers, 
> -Arya 

Mime
View raw message