thrift-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jeremy Levy <jel...@gmail.com>
Subject Problems building on Mac Snow Leopard
Date Fri, 23 Apr 2010 16:18:08 GMT
Hi all,

I'm attempting to build 0.2.0 on Mac Snow Leopard, when I run make I'm
getting the following error and I could use some help in fixing it:

/bin/sh ../../libtool --tag=CXX   --mode=link g++ -Wall -I./src
-I/usr/include -g -O2 -Wall -L/usr/lib  -o thrift thrift-thrifty.o
thrift-thriftl.o thrift-main.o md5.o thrift-t_generator.o
thrift-t_cpp_generator.o thrift-t_java_generator.o
thrift-t_csharp_generator.o thrift-t_py_generator.o thrift-t_rb_generator.o
thrift-t_perl_generator.o thrift-t_php_generator.o thrift-t_erl_generator.o
thrift-t_cocoa_generator.o thrift-t_st_generator.o
thrift-t_ocaml_generator.o thrift-t_hs_generator.o thrift-t_xsd_generator.o
thrift-t_html_generator.o -lfl -lpthread
libtool: Version mismatch error.  This is libtool 2.2.4, but the
libtool: definition of this LT_INIT comes from libtool 2.2.6.
libtool: You should recreate aclocal.m4 with macros from libtool 2.2.4
libtool: and run autoconf again.
make[3]: *** [thrift] Error 63
make[2]: *** [all] Error 2
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2

The only reference to this was here
http://mattmueller.me/blog/installing-thrift-on-snow-leopard which suggested
that I try a nightly however that had other issues...  Any help would be
appreciated.

Jeremy

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message