thrift-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Manuel Vázquez Acosta <mva....@gmail.com>
Subject Failing to build Thrift on Ubuntu 10.04
Date Mon, 14 Jun 2010 03:14:51 GMT
Hi all,

Recently I installed Ubuntu 10.04, and tried to build Thrift. I have built
it successfully on Ubuntu 9.10 before. Now I get this error:

/bin/bash ../../libtool --tag=CXX   --mode=link g++ -Wall -I./src
-I/usr/include -g -O2 -Wall -L/usr/lib  -o thrift thrift-thrifty.o
thrift-thriftl.o thrift-main.o md5.o thrift-t_generator.o
thrift-t_cpp_generator.o thrift-t_java_generator.o thrift-t_as3_generator.o
thrift-t_csharp_generator.o thrift-t_py_generator.o thrift-t_rb_generator.o
thrift-t_perl_generator.o thrift-t_php_generator.o thrift-t_erl_generator.o
thrift-t_cocoa_generator.o thrift-t_st_generator.o
thrift-t_ocaml_generator.o thrift-t_hs_generator.o thrift-t_xsd_generator.o
thrift-t_html_generator.o thrift-t_js_generator.o -lfl -lrt -lpthread
libtool: Version mismatch error.  This is libtool 2.2.6 Debian-2.2.6a-4, but
the
libtool: definition of this LT_INIT comes from libtool 2.2.6b.
libtool: You should recreate aclocal.m4 with macros from libtool 2.2.6
Debian-2.2.6a-4
libtool: and run autoconf again.
make[3]: *** [thrift] Error 63
make[3]: Leaving directory
`/home/manu/src/tests/facebook/thrift/compiler/cpp'
make[2]: *** [all] Error 2
make[2]: Leaving directory
`/home/manu/src/tests/facebook/thrift/compiler/cpp'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/manu/src/tests/facebook/thrift'
make: *** [all] Error 2


I removed the aclocal.m4, so it is rebuilded, but nevertheless I get the
same error. Any ideas?

Best regards,
Manuel.

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message