thrift-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Anthony Molinaro <antho...@alumni.caltech.edu>
Subject Re: libtool version mismatch error on Solaris
Date Mon, 16 Aug 2010 18:03:30 GMT
That seems to be some sort of custom packaging by the hypertable
folks, and from some time ago.  Does it work if you try the
non-solaris version or a recent release version?

http://incubator.apache.org/thrift/download/

-Anthony

On Mon, Aug 16, 2010 at 08:21:02AM +0000, l. daves wrote:
> I have problem compiling thrift on Solaris 10 (SPARC)
> 
> I have libtool 2.2.10, thrift-r820857-solaris from
> http://www.hypertable.org/pub/thrift-r820857-solaris.tgz
> 
> Any idea how can I solve the problem?
> 
> libtool: Version mismatch error.  This is libtool 2.2.6, but the
> libtool: definition of this LT_INIT comes from libtool 2.2.10.
> libtool: You should recreate aclocal.m4 with macros from libtool 2.2.6
> libtool: and run autoconf again.
> gmake[3]: *** [thrift] Error 63
> gmake[3]: Leaving directory `/export/home/smartms/thrift/thrift/compiler/cpp'
> gmake[2]: *** [all] Error 2
> gmake[2]: Leaving directory `/export/home/smartms/thrift/thrift/compiler/cpp'
> gmake[1]: *** [all-recursive] Error 1
> gmake[1]: Leaving directory `/export/home/smartms/thrift/thrift'
> gmake: *** [all] Error 2
> $
> 

-- 
------------------------------------------------------------------------
Anthony Molinaro                           <anthonym@alumni.caltech.edu>

Mime
View raw message