thrift-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kenneth Lareau <Ken.Lar...@nominum.com>
Subject 'Undefined symbol "yylex"' link error building Thrift 0.5.0 on OpenSolaris
Date Thu, 06 Jan 2011 23:00:13 GMT
[CC'ing myself as I'm not subscribed to the mailing list]

After an unsuccessful online search, I decided to attempt to get some help
here.

Trying to build Thrift 0.5.0 on OpenSolaris (b134) with gcc 3.4.3.  The
configure runs fine, but the first attempt at linking fails with an error
regarding an undefined symbol "yylex".  Both flex and bison are installed
on the system.


/bin/sh ../../libtool --tag=CXX   --mode=link g++ -m64 -Wall -I./src -g -O2 
-Wall  -o thrift thrift-thrifty.o thrift-thriftl.o thrift-main.o md5.o 
thrift-t_generator.o thrift-t_cpp_generator.o  thrift-t_as3_generator.o 
thrift-t_py_generator.o           thrift-t_js_generator.o 
thrift-t_javame_generator.o -lfl -lsocket -lrt -lpthread
libtool: link: g++ -m64 -Wall -I./src -g -O2 -Wall -o thrift thrift-thrifty.o 
thrift-thriftl.o thrift-main.o md5.o thrift-t_generator.o 
thrift-t_cpp_generator.o thrift-t_as3_generator.o thrift-t_py_generator.o 
thrift-t_js_generator.o thrift-t_javame_generator.o  -lfl -lsocket -lrt -lpthread
Undefined                       first referenced
  symbol                             in file
yylex                               /usr/lib/amd64/libfl.so
ld: fatal: symbol referencing errors. No output written to thrift
collect2: ld returned 1 exit status
make[3]: *** [thrift] Error 1


The configure line used was:

CC='gcc -m64' CXX='g++ -m64' 
PY_PREFIX=/home/klareau/work/thrift/head/target/py ./configure 
--prefix=/home/klareau/work/thrift/head/target 
--with-boost=/home/klareau/work/boost/1.40.0.1.1/target 
--with-zlib=/home/klareau/work/zlib/1.2.3.9.1/target 
--with-libevent=/home/klareau/work/libevent/head/target --disable-shared 
--disable-gen-java --without-java --disable-gen-csharp --without-csharp 
--disable-gen-erl --without-erlang --disable-gen-perl --without-perl 
--disable-gen-rb --without-ruby --disable-gen-php --disable-gen-cocoa 
--disable-gen-st --disable-gen-ocaml --disable-gen-hs --disable-gen-xsd 
--disable-gen-html


Any suggestions as to what the problem might be here?  If further information
needed to assist in solving this issue, please let me know.

Thanks in advance.


Ken Lareau

Mime
View raw message