thrift-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Abhishek Kona <abhishek.k...@gmail.com>
Subject Re: Issues Starting a Thrift Server in Tomcat
Date Tue, 15 Mar 2011 18:22:47 GMT
On 15/03/11 9:39 PM, Bryan Duxbury wrote:
> Have you tried getting a stack trace of the process?

I have tried. With JSTACK I get the message :

Unable to open socket file: target process not responding or HotSpot VM not loaded

JCONSOLE does not detect the process.
Kill -3 gives the following thread Dump  in Catalina.out  : 
https://gist.github.com/871181

-Kona
> On Tue, Mar 15, 2011 at 12:11 AM, Abhishek Kona<abhishek.kona@gmail.com>wrote:
>
>>   I am trying to create a sample thrift server using TThreadPoolServer
>> (thrift 0.6)
>> This is what the code looks like https://gist.github.com/870405
>>
>> I am running into a very werid issue here.
>> When I run the application using a main function, everything seems to be
>> working fine and the ThriftServer is coming up.
>> But when I start the ThriftServer in a Servlet which loads at Tomcat
>> Startup (see InitServlet.java in the gist), the control is not being
>> returned and I cannot see any logging or system.out statements after the
>> statement
>>
>>             server = new TThreadPoolServer(args);
>>
>>
>> I can telnet into the port at which the thrift service is being started,
>> but the control does not seem to be returning.
>>
>> It would be great if someone could have a look and point out what is
>> happening , is it an issue or am I doing something wrong.
>> Also are there any links on creating a Thrift Java Server using TTHreadPool
>> Server.
>>
>> -Abhishek Kona
>>
>>


Mime
View raw message