thrift-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Zebra Zhao <zebra2mea...@gmail.com>
Subject Re: failed to run php thrift hbase demo code
Date Sun, 23 Oct 2011 13:14:04 GMT
Hi,

I've solved the problem last night. The problem lies in the data strucutre
within the DemoClient.php code.

The the printRow function expect *only one row* as the input parameter.
However, the DemoClinet.php mistakenly take a set of rows that retrieved
from Hbase table as the input for printRow function. The printRow function
cannot handle the arrange of rows, and just simply throws out the no-object
error.

Add the foreach loop outside the printRow can solve this issue.

Best,
Zeb


On Sat, Oct 22, 2011 at 10:10 AM, zebra li <zebra2meadow@gmail.com> wrote:

>
> Hello,
>
> I just installed the thrift 0.70 + hbase 0.90 on a ubuntu box.
>
> I made a simple php thrift client code to scann tables in hbase.
> The code can successfully create hbase table and insert rows to hbase
> tables.
> But, when it try to scann the inserted rows in hbase table, it just return
> null object. I looked up the hbase table within shell, but found the
> inserted rows were in the table. Why my php thrift client code cannot
> retrieves rows from hbase table?
>
> Here is my code in the attachment. The problem lies in  $scanner =
> $client->scannerOpen( $t, "", array "entry:name") );
> Please have a look.
>
> Thanks,
> Zeb
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message