thrift-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jake Farrell <jfarr...@apache.org>
Subject Re: Problems building thrift
Date Wed, 07 Dec 2011 19:25:27 GMT
The ruby build issues are due to dependency version requirements not being met. Installing
rspec version 1.3.2 and mongrel --pre should solve your ruby build issues. 

The python issue is due to PEP3110 and will require updated to the client in order to work.
I will take a look at this and try and get a fix for it here in the next couple days. Until
the patch is available you can skip the python library by using with --without-python flag
when configuring.

- Jake



On Dec 7, 2011, at 1:00 PM, Matthew Shaver wrote:

> I opened a bug THRIFT 1450 with the info you requested.
> 
> Matt.
> 
> 
> On 12/07/2011 09:24 AM, Jake Farrell wrote:
>> Matt, Mike can you answer the following or open a ticket with the following details
and assign it to me please
>> 
>> What OS are you on and can you please provide a list of gems you have installed and
which ruby version you are using.
>> What is your error message you are getting with python 3.x ?
>> What rspec version do you have installed?
>> Do you have bundler installed?
>> 
>> -Jake
>> 
>> 
>> 
>> On Dec 7, 2011, at 2:43 AM, Mike Riley wrote:
>> 
>>> I get this same error when I try to build normally, the fix suggested here:
>>> 
>>> https://issues.apache.org/jira/browse/THRIFT-1367
>>> 
>>> doesn't seem to work for me, but if you're not using ruby, what did work
>>> fine was just disabling it by appending --without-ruby to my configure
>>> command, which is also mentioned there.
>>> 
>>> ~Mike
>>> 
>>> 
>>> 
>>> On Wed, Dec 7, 2011 at 1:51 AM, Matthew Shaver<mshaver@yume.com>  wrote:
>>> 
>>>> Trying to build thrift 0.8.0.  First problem is that it seems the Python
>>>> library for thrift does bit support Python 3.x.
>>>> Next the build fails for the Ruby library with the error below.  I have
>>>> the latest version of Ruby and installed rspec.  Is there something else
I
>>>> am missing?  I guess my next step would be to downgrade to Python 2.x.
>>>> 
>>>> Thanks,
>>>> Matt.
>>>> 
>>>> 
>>>> make[3]: Entering directory `/home/mshaver/dl/thrift-0.8.**0/lib/rb'
>>>> /usr/local/bin/rake
>>>> rake aborted!
>>>> cannot load such file -- spec/rake/spectask
>>>> 
>>>> (See full trace by running task with --trace)
>>>> make[3]: *** [all-local] Error 1
>>>> make[3]: Leaving directory `/home/mshaver/dl/thrift-0.8.**0/lib/rb'
>>>> make[2]: *** [all-recursive] Error 1
>>>> make[2]: Leaving directory `/home/mshaver/dl/thrift-0.8.**0/lib'
>>>> make[1]: *** [all-recursive] Error 1
>>>> make[1]: Leaving directory `/home/mshaver/dl/thrift-0.8.**0'
>>>> make: *** [all] Error 2
>>>> 
>>>> 
> 


Mime
View raw message