thrift-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jake Farrell <jfarr...@apache.org>
Subject Re: Error transferring file: Connection timed out [refused]
Date Tue, 24 Jan 2012 14:40:14 GMT
Maven tries to auto download the dependencies if they are not available within your local repository,
since maven did not know of your proxy it was unable to download them and failed. Adding the
proxy config to your maven settings.xml should resolve your problem from the office (http://maven.apache.org/settings.html#Proxies)

-Jake



On Jan 23, 2012, at 5:54 PM, Anderson, Mark S. wrote:

> I'm trying to build Thrift 0.8.0.  When I do "sudo make install", I get some
> errors in the java directory: "Connection timed out" or "Connection
> refused".
> 
> I'm on Ubuntu 10.04 LTS. I'm behind a firewall.  I have set the HTTP_PROXY
> and JAVA_HOME envars.  I figured out that I needed to add the following to
> build.properties:
> 
> proxy.host=hostname.domain.com
> proxy.port=80
> # username and password are not required to use my proxy
> proxy.user=    
> proxy.pass=
> proxy.enabled=anything
> 
> But, when the script gets to the mvn-init section, I get the following:
> 
> mvn-init:
> . . .
> [artifact:dependencies] Downloading
> org/slf4j/slf4j-api/1.5.8/slf4j-api-1.5.8.pom from repository central at
> http://repo1.maven.org/maven2
> [artifact:dependencies] Error transferring file: Connection timed out
> [artifact:dependencies] [WARNING] Unable to get resource '
> org.slf4j:slf4j-api:pom:1.5.8' from repository central
> (http://repo1.maven.org/maven2): Error transferring file: Connection timed
> out
> . . .
> 
> I get "Connection timed out" when trying to download: 
>  org/slf4j/slf4j-api/1.5.8/slf4j-api-1.5.8.pom 
>  commons-lang/commons-lang/2.5/commons-lang-2.5.pom
>  org/apache/ httpcomponents/httpcore/4.1.3/httpcore-4.1.3.pom
> 
> and I get "Connection refused" when trying to download:
>  javax/servlet/servlet-api/2.5/servlet-api-2.5.pom
>  javax/servlet/servlet-api/2.5/servlet-api-2.5.jar
>  org/apache/httpcomponents/httpclient/4.1.2/httpclient-4.1.2.pom
>  org/apache/ httpcomponents/httpclient/4.1.2/httpclient-4.1.2.jar
>  org/slf4j/slf4j-api/1.5.8/slf4j-api-1.5.8.jar
>  commons-lang/commons-lang/2.5/commons-lang-2.5.jar
>  org/apache/ httpcomponents/httpcore/4.1.3/httpcore-4.1.3.jar
> 
> My Ubuntu is running in a VM (host OS is Windows XP Pro).  When I took my
> host machine out of the office, where I didn't need to use a proxy, "make
> install" worked perfectly.  When I'm in the office, behind the firewall, I
> get the errors.  What's wrong?  Are there some ports that have to be opened
> on the firewall?
> 
> Mark
> (not a Maven or Ant wizard)
> 
> 
> 
> 
> 


Mime
View raw message