thrift-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bryan Duxbury <br...@rapleaf.com>
Subject Re: is thrift 0.5 compatible with 0.8
Date Mon, 27 Feb 2012 18:29:06 GMT
Thrift versions are wire compatible with one another, so you must have some
other issue.

On Mon, Feb 27, 2012 at 3:29 AM, air <cnweike@gmail.com> wrote:

> we use scribe to gather log data from some web servers, we compile scribe
> using thrift 0.5 on all the web servers, and we compile scribe using thrift
> 0.5 in our data center too. but we must send data through a scribe service
> the IDC supplied , but the IDC scribe is compiled using thrift 0.8. there
> are some error log in the IDC scribe service log:
>
> [Mon Feb 27 02:18:19 2012] "Failed to send <1> messages to remote scribe
> server <xxx.xxxx.com:1463> " "error <*EAGAIN *(timed out)>"
> [Mon Feb 27 02:18:19 2*012] "[install_1_1_2_2012-02-27] WARNING:
> Re-queueing 1 messages!" *
> [Mon Feb 27 02:18:19 2012] "Opened connection to remote scribe server <
> xxx.xxxx.com:1463>"
> [Mon Feb 27 02:18:19 2012] "Opened connection to remote scribe server <
> xxx.xxxx.com:1463>"
> [Mon Feb 27 02:18:19 2012] "CONN_POOL: switching to a new connection <
> xxx.xxxx.com:1463>"
> [Mon Feb 27 02:18:19 2012] "Failed to send <1> messages to remote scribe
> server <:5926776> " "*error <No more data to read.>*"
>
> is this related to the thrift version difference ? thank you for your help
> !
>
> --
> 不学习,不知道
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message