thrift-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alex Coventry <coven...@gmail.com>
Subject Some issues with the thrift tutorial and test suite.
Date Tue, 05 Mar 2013 03:11:42 GMT
Hi, I ran into some minor, easy to fix issues while getting thrift 0.9.0
working on linux mint 12.  The first issue I ran into was that the PHP
tests fail when it comes to verifying transmission of 64-bit integers.
 Stepping through some of these tests in the debugger, it appears that it's
sending 2**60 and getting 2**60 back (i.e. it's working as it should) but
the tests are hardcoded to expect to get back 2**60+24 instead.  I don't
know why it does this.

The second issue is that the py.twisted server only seems to work with the
py.twisted client.  (OK, maybe this one isn't so minor for me.)  I tested
it with the php client and the straight py client, and they both failed
with the error message "TSocket read 0 bytes."  It's not clear to me why
it's failing this way, and I would be grateful for some pointers.  For now
I am going to resort to a threadpool-based server.

Also, I didn't come across any documentation indicating that the py.twisted
code should be generated using "thrift --gen py:twisted".  (I.e., you need
a colon between "py" and "twisted," not a period like the tutorial
subdirectory has.)  I had to figure this out  by looking at the makefile
for the test suite.  It'd be nice if that was documented in the tutorial
notes, but just changing the subdirectory name to reflect this would be a
helpful start.

Best regards,
Alex

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message