thrift-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Syao Work <syao.w...@gmail.com>
Subject libthrift.so not found (building deb on ubuntu).
Date Sun, 14 Jul 2013 13:05:45 GMT
Hello,

I am trying to build thrift 0.9 on Ubuntu 13.04 using
create-debian-packages.sh.

First I had some problem with mongel dependency, it wasn't in a repository.
So I installed mongrel with gem install and removed dependency from contol
file to make it build packages.

thrift-compiler_0.9.0_amd64.deb
libthrift0_0.9.0_amd64.deb
libthrift-cil_0.9.0_all.deb
libthrift-dev_0.9.0_amd64.deb
libthrift-java_0.9.0_all.deb
libthrift-perl_0.9.0_all.deb
php5-thrift_0.9.0_amd64.deb
python-thrift_0.9.0_amd64.deb
python-thrift-dbg_0.9.0_amd64.deb
ruby-thrift_0.9.0_all.deb

After installing them all, except libthrift-cil_0.9.0_all.deb (some
dependency problems), I cant find shared library libthrift.so. Static link
library libthrift.a does exist.

What could be the problem? How can I get it built and installed?

Thanks for your answers :)
Syo

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message