thrift-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From ch huang <justlo...@gmail.com>
Subject Re: ERROR: Could not find a valid gem 'lib/rb/thrift*.gem' (>= 0) in any repository when build rpm package
Date Thu, 23 Jan 2014 05:55:20 GMT
hi,here is my procedure of make rpm package,and the attachment s rpmbuild
log

# mkdir -p ~/rpmbuild/SOURCES
# cd ~/rpmbuild/SOURCES
# git clone https://github.com/apache/thrift.git
# mv thrift/ thrift-0.9.1
# cd thrift-0.9.1
# ./bootstrap.sh
# cd ..
# tar zcvf thrift-0.9.1.tar.gz thrift-0.9.1/
# mkdir ~/rpmbuild/SPECS
# cp thrift/contrib/thrift.spec ../SPECS/
# cd ../SPECS/
# rpmbuild -ba thrift.spec
.....
+ mkdir -p ./usr/lib/ruby/gems/1.8
+ CONFIGURE_ARGS='--with-cflags='\''-O2 -g'\'' '
+ gem install -V --local --install-dir ./usr/lib/ruby/gems/1.8 --bindir
./usr/bin --force
'lib/rb/thrift*.gem'
ERROR:  Could not find a valid gem 'lib/rb/thrift*.gem' (>= 0) in any
repository
error: Bad exit status from /var/tmp/rpm-tmp.r1fIu4 (%build)

RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.r1fIu4 (%build)

On Thu, Jan 23, 2014 at 12:07 PM, Nevo Hed <nhed+thriftusr@aereo.com> wrote:

> Hi
>
> Can you send or upload the full buildrpm log
> And list the steps you run prior to buildrpm  (do you git-archive, do you
> use the posted tarball,etc)
>
> Can you be more specific about "getting from github"?  (provide links, and
> why not follow http://thrift.apache.org/developers/ ?)
>
> --Nevo
>
>
> On Wed, Jan 22, 2014 at 8:31 PM, ch huang <justlooks@gmail.com> wrote:
>
> > hi,maillist :
> >            i can not use rpm package of thrift 0.9.0.1,so i build by
> > myself,but when i run rpmbuild ,it build failed,i get thrift from github
> >
> >
> >
> > [root@CH36 SPECS]# rpmbuild -ba thrift.spec
> >
> > thread
> > libtool: link: g++ -Wall -O2 -g -o .libs/TutorialClient CppClient.o
> > -L/usr/lib ./.libs/libtutorialgencpp.a
> > /root/rpmbuild/BUILD/thrift-0.9.1/lib/cpp/.libs/libthrift.so
> > ../../lib/cpp/.libs/libthrift.so -lssl -lcrypto -lrt -lpthread -Wl,-rpath
> > -Wl,/usr/lib64
> > make[3]: Leaving directory
> `/root/rpmbuild/BUILD/thrift-0.9.1/tutorial/cpp'
> > make[3]: Entering directory `/root/rpmbuild/BUILD/thrift-0.9.1/tutorial'
> > ../compiler/cpp/thrift --gen html -r ../tutorial/tutorial.thrift
> > make[3]: Leaving directory `/root/rpmbuild/BUILD/thrift-0.9.1/tutorial'
> > make[2]: Leaving directory `/root/rpmbuild/BUILD/thrift-0.9.1/tutorial'
> > Making all in tutorial
> > make[2]: Entering directory `/root/rpmbuild/BUILD/thrift-0.9.1/tutorial'
> > Making all in cpp
> > make[3]: Entering directory
> > `/root/rpmbuild/BUILD/thrift-0.9.1/tutorial/cpp'
> > make[3]: Nothing to be done for `all'.
> > make[3]: Leaving directory
> `/root/rpmbuild/BUILD/thrift-0.9.1/tutorial/cpp'
> > make[3]: Entering directory `/root/rpmbuild/BUILD/thrift-0.9.1/tutorial'
> > ../compiler/cpp/thrift --gen html -r ../tutorial/tutorial.thrift
> > make[3]: Leaving directory `/root/rpmbuild/BUILD/thrift-0.9.1/tutorial'
> > make[2]: Leaving directory `/root/rpmbuild/BUILD/thrift-0.9.1/tutorial'
> > make[2]: Entering directory `/root/rpmbuild/BUILD/thrift-0.9.1'
> > make[2]: Leaving directory `/root/rpmbuild/BUILD/thrift-0.9.1'
> > make[1]: Leaving directory `/root/rpmbuild/BUILD/thrift-0.9.1'
> > + mkdir -p ./usr/lib/ruby/gems/1.8
> > + CONFIGURE_ARGS='--with-cflags='\''-O2 -g'\'' '
> > + gem install -V --local --install-dir ./usr/lib/ruby/gems/1.8 --bindir
> > ./usr/bin --force 'lib/rb/thrift*.gem'
> > ERROR:  Could not find a valid gem 'lib/rb/thrift*.gem' (>= 0) in any
> > repository
> > error: Bad exit status from /var/tmp/rpm-tmp.YE8IhS (%build)
> >
> > RPM build errors:
> >     Bad exit status from /var/tmp/rpm-tmp.YE8IhS (%build)
> >
> > and i do the following process but no use
> >
> > # cd ../SOURCES/thrift/lib/rb/
> > # gem build thrift.gemspec
> > # gem install --local thrift*.gem
> >
> > anyone can help,or offer a thrift rpm package used on Centos 6
> >
>

Mime
  • Unnamed multipart/mixed (inline, None, 0 bytes)
View raw message