thrift-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Roger Meier <ro...@bufferoverflow.ch>
Subject Re: Why boost 1.54?
Date Mon, 05 Jan 2015 17:12:47 GMT

Quoting Matthew Chambers <mchambers@wetafx.co.nz>:

> Is that version really necessary?   Can it be backed down to 1.51 at  
> least or is 1.54 providing some necessary feature?

Tree/Recursive struct support (THRIFT-2421) requires newer boost version.

I recognized the need of newer boost version here:
https://issues.apache.org/jira/browse/THRIFT-2471

1.53 should be ok as well.
I've never tested an older version or tried to backport...


>
>
> It  doesn't seem like a great dependency to change on a patch  
> release.  For companies with a lot of devs that happen to use boost,  
> its a huge pain to get everyone onto a new boost.

Yes, I have the same issues here.
However Tree/Recursive struct is a important feature and newer distros  
use boost > 1.53.
Debian Jessie will be on 1.55 and it is a header only thing.

good luck!
-roger

>
>
> -=Matt



Mime
View raw message