thrift-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jens Geyer" <jensge...@hotmail.com>
Subject Re: problem installing thrift 0.9.3 (stable recent download) on fedora 22
Date Thu, 15 Oct 2015 22:24:23 GMT
AFAIK you need trial, at least that’s what is checked besides python itself (see configure.ac
line 282)

> configure:20367: checking for trial
> configure:20400: result: no

Have fun,
JensG


From: Achilleas Anastasopoulos 
Sent: Thursday, October 15, 2015 5:48 PM
To: user@thrift.apache.org 
Subject: problem installing thrift 0.9.3 (stable recent download) on fedora 22

Hi all,

I cannot get the --with-python option to work when trying to configure thrift 0.9.3


I use the command:

./configure --prefix=/usr/local     --with-c_glib --with-cpp --with-libevent --with-python
    --without-csharp --without-d --without-erlang --without-go     --without-haskell --without-java
--without-lua --without-nodejs     --without-perl --without-php --without-ruby --without-zlib
    --disable-tests --disable-tutorial      CC=gcc CXX=g++ PY_PREFIX=/usr/local CXXFLAGS="-DNDEBUG"



and get the following output from config at the end:

thrift 0.9.3

Building C++ Library ......... : yes
Building C (GLib) Library .... : yes
Building Java Library ........ : no
Building C# Library .......... : no
Building Python Library ...... : no
Building Ruby Library ........ : no
Building Haxe Library ........ : no
Building Haskell Library ..... : no
Building Perl Library ........ : no
Building PHP Library ......... : no
Building Erlang Library ...... : no
Building Go Library .......... : no
Building D Library ........... : no
Building NodeJS Library ...... : no
Building Lua Library ......... : no

C++ Library:
   Build TZlibTransport ...... : yes
   Build TNonblockingServer .. : yes
   Build TQTcpServer (Qt4) .... : yes
   Build TQTcpServer (Qt5) .... : no

===========


It seems it does not succeed in confguring the Python library.


I also attach the config.log file.


Can someone help me identifying what the issue is.


Thanks

Achilleas









Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message