thrift-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mario Emmenlauer <ma...@emmenlauer.de>
Subject Re: AW: thrift compile with mingw64 fails
Date Fri, 01 Apr 2016 14:47:45 GMT

Dear Jens,

I've tried to fix the issue and make a pull request, but I'm sorry to say
that I don't understand the details of boost's test framework well enough.
It seems the main method is auto-generated when linking the dynamic library.
But I do not know how the corresponding non-auto-generated main() should
look like. I'm afraid I would do more harm than help :-/

All the best,

    Mario




On 01.04.2016 09:04, Jens Geyer wrote:
> Hi Mario
> 
> do you mind creating a patch or pull request? That would be awesome.
> 
> http://thrift.apache.org/docs/HowToContribute
> 
> Have fun,
> JensG
> ________________________________
> Von: Mario Emmenlauer
> Gesendet: 31.03.2016 23:14
> An: user@thrift.apache.org
> Betreff: Re: thrift compile with mingw64 fails
> 
> 
> Dear all,
> 
> it seems I can answer my own question: cmake does not automatically
> detect that the boost unit test library is available as a dll, and
> therefore does not automatically enable WITH_DYN_LINK_TEST. It seems
> some tests are missing a main() method when BOOST_TEST_DYN_LINK is
> not defined, and this define depends on cmake -DWITH_DYN_LINK_TEST=ON.
> I can't say if AllProtocolsTest.cpp should have a main method for
> the case that BOOST_TEST_DYN_LINK is undefined?
> 
> After enabling WITH_DYN_LINK_TEST in cmake, the compile goes beyond
> the problem below.
> 
> Cheers,
> 
>     Mario
> 
> 
> 
> On 29.03.2016 22:36, Mario Emmenlauer wrote:
>>
>> Dear Aki,
>>
>> thanks for the quick reply! I've first tried 0.9.3, and it fails
>> in several places. Then I discovered the fix you pointed out, and
>> since then I've been trying to get newest git trunk compiled. It
>> goes much further, but now I'm stuck here :-(
>>
>> All the best,
>>
>>     Mario Emmenlauer
>>
>>
>> On 29.03.2016 21:33, Aki Sukegawa wrote:
>>> Hi Mario,
>>>
>>> Which version do you use ?
>>> https://issues.apache.org/jira/browse/THRIFT-3437 fixed some problems for
>>> mingw64 but is after 0.9.3 so not yet released.
>>>
>>> On Wed, Mar 30, 2016 at 3:34 AM Mario Emmenlauer <mario@emmenlauer.de>
>>> wrote:
>>>
>>>>
>>>> Hi all,
>>>>
>>>> I'd like to build thrift trunk with mingw64 / msys2 / cmake, but it fails
>>>> at ~43% with an "undefined reference to `WinMain'" in
>>>> AllProtocolsTest.exe.
>>>> I could find some references on the web about unicode builds, and different
>>>> versions of "main()" on Windows. But I failed to find a combination of
>>>> flags that makes the compile work. I would be very happy about any hints,
>>>> did somebody else succeed?


Mime
View raw message