thrift-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From André Reiter <m...@areiter.net>
Subject Thrift version compatibility
Date Thu, 07 Apr 2016 11:44:27 GMT
Hi community,

i could not find an answer to my simple question, so I'll try to get it here.
Currently we are running java based client/server applications using apache thrift version
0.9.0. So all stubs were generated using this version, libthrift version 0.9.0 is used http://search.maven.org/#artifactdetails%7Corg.apache.thrift%7Clibthrift%7C0.9.0%7Cpom<http://search.maven.org/#artifactdetails|org.apache.thrift|libthrift|0.9.0|pom>

Now we need to upgrade the server to the newer version. at least to 0.9.2 or better to the
newset one 0.9.3
due to https://issues.apache.org/jira/browse/THRIFT-2551

Do we need to upgrade all clients out there, or will it be compaitble with older clients ?

Thanks a lot in advance
André

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message