thrift-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Devin Avery <devin.av...@virtualinstruments.com>
Subject configure script using string based version comparison
Date Mon, 06 Mar 2017 14:40:07 GMT
Hello –

I am running the configure script as outlined here for MAC OSx - http://thrift.apache.org/docs/install/os_x

I found that your configure script is doing string based comparison for decency version verification
which breaks as soon as a version changes from one digit to  two. For example, homebrew installs
ant version 1.10.x which is clearly greater than 1.7 which thrift requires. However the thrift
configure script fails to detect ant because it thinks the version is wrong.

This is because this line in the configure script (around line 18844 in 0.9.3) - ANT_VALID=expr
$($ANT -version 2>/dev/null | sed -n 's/.*version \([0-9\.]*\).*/\1/p') \>= 1.7`

Notice how you are using the >= which is STRING comparison, not version comparison. When
1.10.1 compares to 1.7 it is considered LESS than instead of greater than.

Is this a known issue? I would open a Jira item but I don’t have credentials etc.

Thank you,

Devin

Devin Avery




--
________________________________

The contents of this message, together with any attachments, are intended only for the use
of the individual or entity to which they are addressed and may contain confidential information.
If you are not the intended recipient, you are hereby notified that any dissemination, distribution,
or copying of this message, or any attachment, is strictly prohibited. If you have received
this message in error, please contact the sender immediately and permanently delete or destroy
the material/information.
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message