thrift-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "James E. King III" <jk...@apache.org>
Subject Re: Error in installing Thrift library for Lua
Date Wed, 03 Oct 2018 14:51:43 GMT
See if the fix for THRIFT-3863 also takes care of this for you:

https://github.com/apache/thrift/pull/1603

Thanks,

Jim

On Tue, Oct 2, 2018 at 10:16 PM Sudip Datta <sudipdatta10@gmail.com> wrote:

> Hi,
>
> I am trying to build and install Thrift library for Lua and have followed
> instructions on http://thrift.apache.org/docs/install/debian.
>
> I am able to do `make`, however `make install` fails with:
>
> libtool: install: /usr/bin/install -c .libs/libluasocket.lai
> /usr/local/lib/
> libluasocket.la
> libtool: warning: relinking 'libluabpack.la'
> libtool: install: (cd /home/vagrant/thrift-0.11.0/lib/lua; /bin/bash
> "/home/vagrant/thrift-0.11.0/libtool"  --tag CC --mode=relink gcc -g -O2 -o
> libluabpack.la -rpath /usr/local/lib src/libluabpack_la-luabpack.lo
> liblualongnumber.la -llua5.3 -ldl -lm -lrt -lpthread )
> mv: cannot stat 'libluabpack.so.0.0.0': No such file or directory
> libtool:   error: error: relink 'libluabpack.la' with the above command
> before installing it
> Makefile:659: recipe for target 'install-libLTLIBRARIES' failed
> make[4]: *** [install-libLTLIBRARIES] Error 1
>
> The complete trace is at: https://pastebin.com/ixPz6tvG
>
> Any help will be appreciated.
>
> Thanks,
> Sudip
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message