tika-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jukka Zitting (JIRA)" <j...@apache.org>
Subject [jira] Updated: (TIKA-9) Make source code compilable on Java 1.4 by removing Java 5 features such as generics.
Date Mon, 17 Sep 2007 10:07:32 GMT

     [ https://issues.apache.org/jira/browse/TIKA-9?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Jukka Zitting updated TIKA-9:
-----------------------------

      Priority: Minor  (was: Major)
    Issue Type: Improvement  (was: Task)

I'm also not too tied to 1.4 as the baseline platform, but I'd prefer if we had some concrete
benefits from Java 5 to outweight not supporting 1.4. The current use of generics is IMHO
not too essential to the code, but if there are also other new features we'd like to use then
I wouldn't mind dropping 1.4 support.

What classloading changes in Java 5 do you think would help us?

> Make source code compilable on Java 1.4 by removing Java 5 features such as generics.
> -------------------------------------------------------------------------------------
>
>                 Key: TIKA-9
>                 URL: https://issues.apache.org/jira/browse/TIKA-9
>             Project: Tika
>          Issue Type: Improvement
>          Components: general
>    Affects Versions: 0.1-incubator
>            Reporter: Keith R. Bennett
>            Priority: Minor
>
> A concensus was reached to make the library Java 1.4 compatible.
> Some source files have generics (e.g. List<String>).  
> These need to be removed so that the library is 1.4 compatible.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message