tika-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jukka Zitting (JIRA)" <j...@apache.org>
Subject [jira] Created: (TIKA-196) Configuration parser fails in Java 1.4
Date Tue, 03 Feb 2009 20:39:59 GMT
Configuration parser fails in Java 1.4
--------------------------------------

                 Key: TIKA-196
                 URL: https://issues.apache.org/jira/browse/TIKA-196
             Project: Tika
          Issue Type: Bug
          Components: config
    Affects Versions: 0.2
            Reporter: Jukka Zitting
            Assignee: Jukka Zitting
            Priority: Critical
             Fix For: 0.3


As reported by Dmitry Kudryavtsev on the mailing list, the TikaConfig class does not work
on Java 1.4 even in the retrotranslated -jdk14 version.

Dmitry explains:
> I would like to suggest a minor patch for TikaConfig for backward
> compatibilities  with java 1.4
> Here it is:
> ===>
> ...
> parsers.put(mime.getTextContent().trim(), parser);
> ...
> <===
> 
> in  constructor TikaConfig(Element element) should be replaced with code
> like:
> 
> ===>
> Node txtNode = mime.getFirstChild();
> if ( txtNode != null ){
>    parsers.put(txtNode.getNodeValue().trim(), parser);
> }
> <===
> 
> This is important because Node.getTextContent not available in java 1.4 and
> tika-jdk1.4 become useless.



-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message