tika-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Raimund Merkert (JIRA)" <j...@apache.org>
Subject [jira] [Created] (TIKA-650) Missing required alt attribute on img tag
Date Sun, 01 May 2011 05:55:03 GMT
Missing required alt attribute on img tag
-----------------------------------------

                 Key: TIKA-650
                 URL: https://issues.apache.org/jira/browse/TIKA-650
             Project: Tika
          Issue Type: Bug
          Components: parser
    Affects Versions: 0.9
            Reporter: Raimund Merkert


I've written a content handler that prints out the xhtml tags for conversion from a word document
with embedded images. For images, it does not generate the "alt" attribute for img tags, which
causes validation to fail. alt is a required attribute in XHTML.

Here's a partial output from [http://validator.w3.org/check]:

{quote}
Error Line 3, Column 1026: required attribute "alt" not specified

...meta><title> </title></head><body><p><img src="embedded:image63.jpg"></img></p>

‚úČ

The attribute given above is required for an element that you've used, but you have omitted
it. For instance, in most HTML and XHTML document types the "type" attribute is required on
the "script" element and the "alt" attribute is required for the "img" element.

Typical values for type are type="text/css" for <style> and type="text/javascript" for
<script>.
{quote}


--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message