tika-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tom Gross <itconse...@gmail.com>
Subject Re: Tika 0.9 integration in Solr 3.3.0
Date Thu, 25 Aug 2011 08:16:32 GMT
You need to overwrite ALL the relevant jars of the updated components. 
These supposed to be:

tika 0.9:

commons-codec-1.2.jar
geronimo-stax-api_1.0_spec-1.0.1.jar
jdom-1.0.jar
slf4j-api-1.5.6.jar
tika-core-0.9.jar
tika-parsers-0.9.jar


pdfbox 1.6.0:

fontbox-1.6.0.jar
jempbox-1.6.0.jar
pdfbox-1.6.0.jar


poi 3.8-beta3:

poi-3.8-beta3-20110606.jar
poi-ooxml-3.8-beta3-20110606.jar
poi-ooxml-schemas-3.8-beta3-20110606.jar
poi-scratchpad-3.8-beta3-20110606.jar

HTH
-Tom


On 08/22/2011 11:33 AM, Jukka Zitting wrote:
> Hi,
>
> On Mon, Aug 22, 2011 at 11:08 AM, nirnaydewan<nirnaydewan@gmail.com>  wrote:
>> Please let me know how can i get rid of this exception.
>
> It looks like you have a dependency version mismatch. Instead of POI
> version -3.8-beta3-20110606 use the earlier 3.6 version as listed in
> the Tika 0.9 getting started page [1].
>
> If you want to use a more recent POI version, you need to use the
> latest Tika 1.0-SNAPSHOT version from svn trunk.
>
> [1] http://tika.apache.org/0.9/gettingstarted.html
>
> BR,
>
> Jukka Zitting
>


-- 
Author of the book "Plone 3 Multimedia" - http://amzn.to/dtrp0C

Tom Gross
email..........tom@toms-projekte.de
skype.....................tom_gross
web.........http://toms-projekte.de
blog...http://blog.toms-projekte.de


Mime
View raw message