tika-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Nick Burch (Commented) (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (TIKA-897) UTF-8 encoded XML is detected as text/plain because of UTF-8 BOM
Date Fri, 20 Apr 2012 13:34:39 GMT

    [ https://issues.apache.org/jira/browse/TIKA-897?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13258241#comment-13258241
] 

Nick Burch commented on TIKA-897:
---------------------------------

We had support for detecting XML files that are ASCII, UTF-8 no-BOM, UTF-16LE and UTF-16BE.

In r1328370 I've added detection + unit test for UTF-8 with a BOM

We don't detect XML in UTF-32 (with or without BOMs), but I'm not sure if that's worth adding
or not?
                
> UTF-8 encoded XML is detected as text/plain because of UTF-8 BOM
> ----------------------------------------------------------------
>
>                 Key: TIKA-897
>                 URL: https://issues.apache.org/jira/browse/TIKA-897
>             Project: Tika
>          Issue Type: Bug
>          Components: mime
>    Affects Versions: 1.1
>            Reporter: Wade Taylor
>            Priority: Minor
>
> Detection of XML fails when encoded as UTF-8. The UTF-8 BOM: 0xEF,0xBB,0xBF causes the
XML detector to fail when trying to match "<?xml" at the beginning of the input stream.
>  

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message