tika-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jörg Ehrlich (JIRA) <j...@apache.org>
Subject [jira] [Commented] (TIKA-811) Upgrade metadatExtractor version for OpenJDK 7 support
Date Fri, 29 Jun 2012 09:29:44 GMT

    [ https://issues.apache.org/jira/browse/TIKA-811?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13403798#comment-13403798
] 

Jörg Ehrlich commented on TIKA-811:
-----------------------------------

Tika can integrate with version 5.1.1 of the XMPCore library. Version 5.1.0 had accidentally
been compiled for JDK 1.7 which is incompatible with Tika. But Version 5.1.1 is compatible
with Tika.
                
> Upgrade metadatExtractor version for OpenJDK 7 support
> ------------------------------------------------------
>
>                 Key: TIKA-811
>                 URL: https://issues.apache.org/jira/browse/TIKA-811
>             Project: Tika
>          Issue Type: Bug
>          Components: parser
>    Affects Versions: 1.0, 1.1
>         Environment: OpenJDK 7
>            Reporter: Emmanuel Hugonnet
>              Labels: patch, upgrade
>         Attachments: metadata.diff
>
>
> The metadataextractor library (2.4.0-beta-1) is quite old and is depending on some Sun
classes thus making it unable to run on openJDK 7 which is now the default JDK on Linux distributions.
> Upgrading the library to the new version 2.5.0-RC3 fixes this issue but the API has changed.
> Appending a patch to the MetadataExtactor class (and the tests) to take advantage of
this.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

       

Mime
View raw message