tika-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Chris A. Mattmann (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (TIKA-1378) MicrosoftTranslator setClient and setId NPE
Date Tue, 29 Jul 2014 13:11:38 GMT

    [ https://issues.apache.org/jira/browse/TIKA-1378?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14077690#comment-14077690
] 

Chris A. Mattmann commented on TIKA-1378:
-----------------------------------------

https://reviews.apache.org/r/24051/

> MicrosoftTranslator setClient and setId NPE
> -------------------------------------------
>
>                 Key: TIKA-1378
>                 URL: https://issues.apache.org/jira/browse/TIKA-1378
>             Project: Tika
>          Issue Type: Bug
>          Components: translation
>         Environment: Discovered while using https://github.com/chrismattmann/tika-python
and https://github.com/chrismattmann/etllib on DARPA XDATA.
>            Reporter: Chris A. Mattmann
>            Assignee: Chris A. Mattmann
>             Fix For: 1.6
>
>         Attachments: TIKA-1378.Mattmann.072914.patch.txt
>
>
> I introduced a bug in MicrosoftTranslator when I was checking for isAvailable in the
#setClient and #setId methods that produces and NPE when both aren't set. The Translator still
works when auto configured, just not when explicitly configured.
> I'll add a patch and unit test. (thanks to [~tpalsulich] for the idea on the unit test).



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message