tika-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hudson (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (TIKA-1378) MicrosoftTranslator setClient and setId NPE
Date Tue, 29 Jul 2014 23:48:38 GMT

    [ https://issues.apache.org/jira/browse/TIKA-1378?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14078633#comment-14078633
] 

Hudson commented on TIKA-1378:
------------------------------

SUCCESS: Integrated in tika-trunk-jdk1.7 #129 (See [https://builds.apache.org/job/tika-trunk-jdk1.7/129/])
- TIKA-1378: MicrosoftTranslator setClient and setId NPE (thanks to tpalsulich for the review!)
(mattmann: http://svn.apache.org/viewvc/tika/trunk/?view=rev&rev=1614488)
* /tika/trunk/tika-translate/src/main/java/org/apache/tika/language/translate/MicrosoftTranslator.java
* /tika/trunk/tika-translate/src/test/java/org/apache/tika/language/translate/MicrosoftTranslatorTest.java


> MicrosoftTranslator setClient and setId NPE
> -------------------------------------------
>
>                 Key: TIKA-1378
>                 URL: https://issues.apache.org/jira/browse/TIKA-1378
>             Project: Tika
>          Issue Type: Bug
>          Components: translation
>         Environment: Discovered while using https://github.com/chrismattmann/tika-python
and https://github.com/chrismattmann/etllib on DARPA XDATA.
>            Reporter: Chris A. Mattmann
>            Assignee: Chris A. Mattmann
>             Fix For: 1.6
>
>         Attachments: TIKA-1378.Mattmann.072914.patch.txt
>
>
> I introduced a bug in MicrosoftTranslator when I was checking for isAvailable in the
#setClient and #setId methods that produces and NPE when both aren't set. The Translator still
works when auto configured, just not when explicitly configured.
> I'll add a patch and unit test. (thanks to [~tpalsulich] for the idea on the unit test).



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message