tika-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tim Allison (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (TIKA-1427) PDF Images don't appear in structured view
Date Thu, 09 Oct 2014 19:38:34 GMT

    [ https://issues.apache.org/jira/browse/TIKA-1427?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14165619#comment-14165619
] 

Tim Allison commented on TIKA-1427:
-----------------------------------

I also can't seem to find the image when I run PDFBox app's PDFDebugger, but I do see the
image with PDFReader.  Wait, is that it encoded in the page's Contents:stream 
{noformat}
ET Q q 229.76 139.01 135.9535 146.0508 re W n 300.303 283.8247 m 298.8738
283.8945 l 297.4924 283.8945 l 296.135 283.7549 l 294.8264 283.5356 l 293.47
283.3163 l 292.2342 282.9574 l 
{noformat}

I also can't click on it in Adobe Reader, like the other image and copy/paste it.

> PDF Images don't appear in structured view
> ------------------------------------------
>
>                 Key: TIKA-1427
>                 URL: https://issues.apache.org/jira/browse/TIKA-1427
>             Project: Tika
>          Issue Type: Bug
>          Components: parser
>    Affects Versions: 1.6
>            Reporter: James Baker
>            Assignee: Tim Allison
>              Labels: pdf
>         Attachments: images_test.pdf
>
>
> When viewing, say, a Word Document, any images appear in the 'structured view' of the
document as <img> tags. The same is not true of PDF documents, and we lose both the
fact that there is an image present, and where it is in the document.
> Some discussion of this issue in the comments of TIKA-1396.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message