tika-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alexander Pogrenbyak (JIRA)" <j...@apache.org>
Subject [jira] [Created] (TIKA-1749) Upgrade, or shade, guava
Date Wed, 23 Sep 2015 19:37:04 GMT
Alexander Pogrenbyak created TIKA-1749:
------------------------------------------

             Summary: Upgrade, or shade, guava
                 Key: TIKA-1749
                 URL: https://issues.apache.org/jira/browse/TIKA-1749
             Project: Tika
          Issue Type: Bug
          Components: parser
    Affects Versions: 1.10
            Reporter: Alexander Pogrenbyak


I use managed dependencies and have guava managed to version 18.0.

The tika-parsers project has guava version 11.0.2

I have a concern that managing up guava 18.0 may break something in Tika code.

Besides the fact that 11.0.2 is deprecated a long time ago, if Tika has dependency on a particular
version it should shade it for its use.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message