tika-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tim Allison (JIRA)" <j...@apache.org>
Subject [jira] [Created] (TIKA-2368) Clean up SentimentParser dependencies
Date Wed, 17 May 2017 12:16:04 GMT
Tim Allison created TIKA-2368:
---------------------------------

             Summary: Clean up SentimentParser dependencies
                 Key: TIKA-2368
                 URL: https://issues.apache.org/jira/browse/TIKA-2368
             Project: Tika
          Issue Type: Improvement
            Reporter: Tim Allison
            Priority: Blocker


Is there any way to avoid reliance on edu.usc.ir's sentiment-analysis-parser?  I ask because:

{noformat}
[WARNING] sentiment-analysis-parser-0.1.jar, tika-parsers-1.15-SNAPSHOT.jar define 1 overlapping
classes: 
[WARNING]   - org.apache.tika.parser.sentiment.analysis.SentimentParser
[WARNING] tika-core-1.15-SNAPSHOT.jar, tika-translate-1.15-SNAPSHOT.jar define 4 overlapping
classes: 
[WARNING]   - org.apache.tika.language.translate.DefaultTranslator$1
[WARNING]   - org.apache.tika.language.translate.EmptyTranslator
[WARNING]   - org.apache.tika.language.translate.DefaultTranslator
[WARNING]   - org.apache.tika.language.translate.Translator
{noformat}

We should be ok keeping things as they are and excluding SentimentParser and tika-translate,
but can we easily move the code that's still in edu.usc.ir's package into Tika?



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message