tika-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hudson (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (TIKA-2535) Use latest org.opengis:geoapi to avoid rejected/EOL'd jsr-275 dependency
Date Tue, 23 Jan 2018 21:48:00 GMT

    [ https://issues.apache.org/jira/browse/TIKA-2535?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16336417#comment-16336417
] 

Hudson commented on TIKA-2535:
------------------------------

SUCCESS: Integrated in Jenkins build Tika-trunk #1423 (See [https://builds.apache.org/job/Tika-trunk/1423/])
Update geo-apis and sis to avoid license problems (TIKA-2535 and (tallison: [https://github.com/apache/tika/commit/6bd187a4d1ae9d82afc6943c0a89d23aa9f50ec2])
* (edit) CHANGES.txt
* (edit) tika-parsers/pom.xml
TIKA-2535 - fix bundle requirements (tallison: [https://github.com/apache/tika/commit/fb68c39a58819afaf2e80f8a67b90d5817506ea2])
* (edit) tika-bundle/pom.xml
TIKA-2535 -- fix test in tika-java7 to handle new sis StoreTypeDetector (tallison: [https://github.com/apache/tika/commit/a08c07e50e62bf63c893a0197ff185e7ed580e73])
* (edit) tika-java7/src/test/java/org/apache/tika/filetypedetector/TikaFileTypeDetectorTest.java


> Use latest org.opengis:geoapi to avoid rejected/EOL'd jsr-275 dependency
> ------------------------------------------------------------------------
>
>                 Key: TIKA-2535
>                 URL: https://issues.apache.org/jira/browse/TIKA-2535
>             Project: Tika
>          Issue Type: Improvement
>          Components: parser
>    Affects Versions: 1.16, 1.17
>         Environment: All
>            Reporter: Richard Jones
>            Assignee: Tim Allison
>            Priority: Major
>             Fix For: 2.0, 1.18
>
>
> Tika currently depends on the very old (June 2011) 3.0.0 version of org.opengis:geoapi
> which in turn unfortunately pulls in the rejected jsr-275 as a dependency (which is EOL).
> However the latest 3.0.1 version of org.opengis:geoapi released recently (Sept 2017)
switches to depending on the active 1.0 version of javax.measure.unit-api which is an implementation
of jsr-363 which was accepted and effectively replaced the rejected jsr-275.
> Therefore requesting that Tika move to the 3.0.1 version of org.opengis:geoapi



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message