tika-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Guillaume Smet (JIRA)" <j...@apache.org>
Subject [jira] [Created] (TIKA-2598) Fix dependency convergence
Date Mon, 05 Mar 2018 10:25:00 GMT
Guillaume Smet created TIKA-2598:
------------------------------------

             Summary: Fix dependency convergence
                 Key: TIKA-2598
                 URL: https://issues.apache.org/jira/browse/TIKA-2598
             Project: Tika
          Issue Type: Improvement
          Components: packaging
    Affects Versions: 1.17
            Reporter: Guillaume Smet


Hi,

We tried to upgrade Tika to 1.17 in Hibernate Search and we had some dependency convergence
issues:

{code}
Dependency convergence error for com.healthmarketscience.jackcess:jackcess:2.1.8 paths to
dependency are:
+-org.hibernate:hibernate-search-engine:5.10.0-SNAPSHOT
    +-org.apache.tika:tika-parsers:1.17
         +-com.healthmarketscience.jackcess:jackcess:2.1.8
and
+-org.hibernate:hibernate-search-engine:5.10.0-SNAPSHOT
     +-org.apache.tika:tika-parsers:1.17
         +-com.healthmarketscience.jackcess:jackcess-encrypt:2.1.2
             +-com.healthmarketscience.jackcess:jackcess:2.1.0
{code}

We could fix them downstream in Hibernate Search but I thought it would be better if Tika
could ensure the convergence of its dependencies using the Maven enforcer plugin so that all
the downstream projects can benefit from it.

Thanks.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message