tika-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hudson (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (TIKA-2672) Upgrade dl4j to 1.0.0-beta2
Date Tue, 14 Aug 2018 17:14:00 GMT

    [ https://issues.apache.org/jira/browse/TIKA-2672?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16580094#comment-16580094
] 

Hudson commented on TIKA-2672:
------------------------------

SUCCESS: Integrated in Jenkins build tika-branch-1x #76 (See [https://builds.apache.org/job/tika-branch-1x/76/])
TIKA-2672 -- upgrade deeplearning4j to 1.0.0-beta2 via Thejan (tallison: [https://github.com/apache/tika/commit/f44e109d423ac99e74cc55fc78c7daf4fb81a8fd])
* (edit) tika-dl/src/main/java/org/apache/tika/dl/imagerec/DL4JVGG16Net.java
* (edit) tika-dl/src/main/java/org/apache/tika/dl/imagerec/DL4JInceptionV3Net.java
* (delete) tika-dl/src/main/resources/org/apache/tika/dl/imagerec/inceptionv3-model.json
* (edit) tika-dl/src/test/java/org/apache/tika/dl/imagerec/DL4JVGG16NetTest.java
* (edit) tika-dl/pom.xml
* (edit) tika-dl/src/test/resources/org/apache/tika/dl/imagerec/dl4j-inception3-config.xml
* (delete) tika-dl/src/main/resources/org/apache/tika/dl/imagerec/imagenet_incpetionv3_class_index.json
* (edit) tika-dl/src/test/java/org/apache/tika/dl/imagerec/DL4JInceptionV3NetTest.java


> Upgrade dl4j to 1.0.0-beta2
> ---------------------------
>
>                 Key: TIKA-2672
>                 URL: https://issues.apache.org/jira/browse/TIKA-2672
>             Project: Tika
>          Issue Type: Task
>            Reporter: Tim Allison
>            Priority: Major
>             Fix For: 1.19, 2.0.0
>
>         Attachments: TIKA-2672.patch
>
>
> Let's try to upgrade dl4j.  I think I got us most of the way there, but I got this error
when reading the json config file.  Can someone with more knowledge of layer specs help ([~thammegowda],
perhaps :))?
> {noformat}
> org.deeplearning4j.exception.DL4JInvalidConfigException: Invalid configuration for layer
(idx=-1, name=convolution2d_2, type=ConvolutionLayer) for width dimension:  Invalid input
configuration for kernel width. Require 0 < kW <= inWidth + 2*padW; got (kW=3, inWidth=1,
padW=0)
> Input type = InputTypeConvolutional(h=149,w=1,c=32), kernel = [3, 3], strides = [1, 1],
padding = [0, 0], layer size (output channels) = 32, convolution mode = Truncate
> {noformat}



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message