tika-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tim Allison (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (TIKA-2676) After switching to TIKA 1.18 from 1.17 started to get exception
Date Tue, 18 Sep 2018 20:55:00 GMT

    [ https://issues.apache.org/jira/browse/TIKA-2676?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16619701#comment-16619701
] 

Tim Allison commented on TIKA-2676:
-----------------------------------

{quote}bq. We're passing null as a content type, in this case. All other cases where we
do pass content type were working fine. I don't get your question 
{quote}
It looks from your initial description like the error is happening during the initialization
of ActivationDataFlavor.  The MimeTypeParseException will occur when the mimetype that is
passed in is invalid.  So, my question is...are you running Tika against a file and then
trying to create an ActivationDataFlavor with a mime-type that you've gotten from Tika. 
I'm trying to understand your workflow.
{quote}I'll ask from dev team to upgrade to 1.18 and run with extended logging
{quote}
1.19 is just out.  Give that a try. :D
{quote}Question are AutoDetectParser and other TIKA parsers in general are thread-safe ?
as it could be that we have about 15 threads that each of then will have its own Parser
{quote}
Yes, absolutely.  If you find that they are not, let us know!!!  Our regression tests run
multi-threaded on a single parser.

> After switching to TIKA 1.18 from 1.17 started to get exception
> ---------------------------------------------------------------
>
>                 Key: TIKA-2676
>                 URL: https://issues.apache.org/jira/browse/TIKA-2676
>             Project: Tika
>          Issue Type: Bug
>         Environment: CentOS 7 running on Amazon EC2 I3.Xlarge. With JAVA 8 update 60.
>            Reporter: Slava G
>            Priority: Major
>
> I recently switched from TIKA 1.17 to TIKA 1.18 (I'm using tika to parse emails).
> And I started to get exceptions in :
> IllegalArgumentException: failed to parse:
>   at java.lang.IllegalArgumentException: failed to parse:
>   at java.awt.datatransfer.DataFlavor.<init>(DataFlavor.java:435)
>   at javax.activation.ActivationDataFlavor.<init>(ActivationDataFlavor.java:81)
> I'm using AutoDetectParser.
> The DataFlavor constructor throws an exception when it catches MimeTypeParseException
during initialization when can't recognize MIME type and indeed mimeType that printed in
the log is something not printable.
> This started to happen in the production environment , when I'm tried to reproduce it
in my workstation it was not reproducible, switched back to TIKA 1.17 solved the issue. 
>  
> Thanks



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message