tika-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Slava G (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (TIKA-2676) After switching to TIKA 1.18 from 1.17 started to get exception
Date Tue, 18 Sep 2018 21:05:00 GMT

    [ https://issues.apache.org/jira/browse/TIKA-2676?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16619714#comment-16619714
] 

Slava G commented on TIKA-2676:
-------------------------------

Well, the flow is next, we're parsing MimeMessage, taking kust budy as string. Making byte[]
from it and then making TikaStream by using  TikaInputStream.get(byte[]).

Then we're calling detect method on AutoDetectParser.getDetector().detect() with TikaStream
and content type null.

Once we're getting content type, we're calling AutoDetectParser.parse() with TikaStream and
content type.

 

As for 1.19 - will try on it :)

 

Thanks

> After switching to TIKA 1.18 from 1.17 started to get exception
> ---------------------------------------------------------------
>
>                 Key: TIKA-2676
>                 URL: https://issues.apache.org/jira/browse/TIKA-2676
>             Project: Tika
>          Issue Type: Bug
>         Environment: CentOS 7 running on Amazon EC2 I3.Xlarge. With JAVA 8 update 60.
>            Reporter: Slava G
>            Priority: Major
>
> I recently switched from TIKA 1.17 to TIKA 1.18 (I'm using tika to parse emails).
> And I started to get exceptions in :
> IllegalArgumentException: failed to parse:
>   at java.lang.IllegalArgumentException: failed to parse:
>   at java.awt.datatransfer.DataFlavor.<init>(DataFlavor.java:435)
>   at javax.activation.ActivationDataFlavor.<init>(ActivationDataFlavor.java:81)
> I'm using AutoDetectParser.
> The DataFlavor constructor throws an exception when it catches MimeTypeParseException
during initialization when can't recognize MIME type and indeed mimeType that printed in
the log is something not printable.
> This started to happen in the production environment , when I'm tried to reproduce it
in my workstation it was not reproducible, switched back to TIKA 1.17 solved the issue. 
>  
> Thanks



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message