tika-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "James Baker (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (TIKA-2719) Java 9: Requiring tika-parsers from module-info.java fails with "module not found"
Date Mon, 10 Sep 2018 09:40:00 GMT

    [ https://issues.apache.org/jira/browse/TIKA-2719?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16608934#comment-16608934
] 

James Baker commented on TIKA-2719:
-----------------------------------

With the latest snapshot build, this now seems to work correctly. I also had to require the
`java.xml` module for some of the dependencies to work. Thanks.

> Java 9: Requiring tika-parsers from module-info.java fails with "module not found"
> ----------------------------------------------------------------------------------
>
>                 Key: TIKA-2719
>                 URL: https://issues.apache.org/jira/browse/TIKA-2719
>             Project: Tika
>          Issue Type: Bug
>          Components: parser
>    Affects Versions: 1.18
>            Reporter: James Baker
>            Priority: Major
>              Labels: java9, module
>
> When requiring `tika.parsers` from a Java 9 `module-info.java`, Maven throws an error
about not being able to find `tika.parsers`:
>  
> {{[ERROR] Failed to execute goal org.apache.maven.plugins:maven-compiler-plugin:3.7.0:compile
(default-compile) on project annot8-components-tika: Compilation failure}}
> {{[ERROR] /home/bakerj/annot8/annot8-components/annot8-components-tika/src/main/java/module-info.java:[9,16]
module not found: tika.parsers}}
>  
> It looks like this is likely to be a similar issue to: [https://github.com/elastic/elasticsearch/issues/28984]
> For an example of a failing project, see: [https://github.com/annot8/annot8-components/tree/tika]



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message