tika-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hudson (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (TIKA-2792) Upgrade mp4parser dependency
Date Mon, 03 Dec 2018 21:07:00 GMT

    [ https://issues.apache.org/jira/browse/TIKA-2792?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16707791#comment-16707791
] 

Hudson commented on TIKA-2792:
------------------------------

SUCCESS: Integrated in Jenkins build Tika-trunk #1604 (See [https://builds.apache.org/job/Tika-trunk/1604/])
TIKA-2792 -- upgrade dependency coordinates for MP4Parser (tallison: [https://github.com/apache/tika/commit/3239f24863d5980395a6951e02e42fc9defcb37e])
* (edit) tika-parsers/src/main/java/org/apache/tika/parser/mp4/MP4Parser.java
* (edit) tika-parsers/pom.xml
* (edit) CHANGES.txt
* (delete) tika-parsers/src/main/java/org/apache/tika/parser/mp4/DirectFileReadDataSource.java


> Upgrade mp4parser dependency
> ----------------------------
>
>                 Key: TIKA-2792
>                 URL: https://issues.apache.org/jira/browse/TIKA-2792
>             Project: Tika
>          Issue Type: Improvement
>            Reporter: Tim Allison
>            Assignee: Tim Allison
>            Priority: Major
>             Fix For: 2.0.0, 1.20
>
>
> It looks like [~sannies] has moved development of the mp4parser originally from googlecode
over to: 
> <dependency>
>     <groupId>org.mp4parser</groupId>
>     <artifactId>isoparser</artifactId>
>     <version>1.9.36</version>
> </dependency>
> Let's upgrade to that.  I tried upgrading to 1.9.37, but that artifact was built with
jdk9, and I got the now-semi-expected error: {{Method rewind()Ljava/nio/ByteBuffer; does not
exist in class java.nio.ByteBuffer}}



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message