tiles-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Marcus Oenicke <m.oeni...@it4u-berlin.biz>
Subject InsertAttributeTag reports Attribute 'header' not found
Date Tue, 08 May 2007 21:46:11 GMT

Hi,
I'm working with Tiles 2.0.3 and Struts 2.0.6 in a Tomcat 5.5.20
environment.

Maybe I haven't succeeded in dropping all references to previous versions of
Tiles, including the one delivered with Struts 2, since I keep experiencing
the following TilesException:

23:15:16,816 ERROR RoleSecurityTagSupport:80 - Error executing tag:
Attribute 'header' not found.
org.apache.tiles.TilesException: Attribute 'header' not found.
	at
org.apache.tiles.jsp.taglib.InsertAttributeTag.render(InsertAttributeTag.java:113)
	at
org.apache.tiles.jsp.taglib.RenderTagSupport.execute(RenderTagSupport.java:172)
	at
org.apache.tiles.jsp.taglib.RoleSecurityTagSupport.doEndTag(RoleSecurityTagSupport.java:76)
	at
org.apache.tiles.jsp.taglib.ContainerTagSupport.doEndTag(ContainerTagSupport.java:82)
	at
org.apache.jsp.jsp.tiles.hv_005fmain_jsp._jspx_meth_tiles_insertAttribute_0(hv_005fmain_jsp.java:98)
...

This looks very similar to issue TILES-121 which was reported for version
2.0.1, but I don't expect the same cause, really.

I use the following entry in tiles-defs.xml, including the corrected uri for
the DTD:

<!DOCTYPE tiles-definitions PUBLIC
       "-//Apache Software Foundation//DTD Tiles Configuration 2.0//EN"
       "org/apache/tiles/resources/tiles-config_2_0.dtd">
       
<tiles-definitions>
	<definition name="basicLayout" template="/jsp/tiles/hv_main.jsp">
		<put-attribute name="header" type="template" value="/jsp/tiles/header.jsp"
/>
	</definition>
</tiles-definitions>       

The hv_main.jsp looks like this:

<%@ taglib uri="http://tiles.apache.org/tags-tiles" prefix="tiles" %>

<html>
	<head></head>
	<body">
		<tiles:insertAttribute name="header" />
		<div id="body">this is the body</div>
	</body>
</html>

I have included the following JARs in WEB-INF/lib:

- tiles-api-2.0.3.jar
- tiles-core-2.0.3.jar
- tiles-jsp-2.0.3.jar
- struts2-core-2.0.6.jar

I have removed the struts2-tiles-plugin-2.0.6.jar to prevent negative
interaction, but it didn't change anything.
Anything wrong so far?

Very grateful for any tip,
Marcus
-- 
View this message in context: http://www.nabble.com/InsertAttributeTag-reports-Attribute-%27header%27-not-found-tf3712428.html#a10384675
Sent from the tiles users mailing list archive at Nabble.com.


Mime
View raw message