tiles-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Adam Nichols <mr.adam.nich...@gmail.com>
Subject Re: nothing in my view
Date Thu, 25 Dec 2008 03:58:14 GMT
Yeah, I ended up just copying over the web.xml which worked in the 
example .war file but to no avail.  Here's the web.xml entry:
       <!-- Tiles ViewHandler config file --> 	
      <context-param> 	
          <param-name>tiles-definitions</param-name> 	
          <param-value>/WEB-INF/tiles.xml</param-value> 	
      </context-param>

and the entry from faces-config.xml:
<application>
<view-handler>org.apache.myfaces.tomahawk.application.jsp.JspTilesTwoViewHandlerImpl</view-handler>
</application>

I'm going to try to create an identical project to the example .war file 
and see if I can get things working.  I'll post back if I have any success.

--Adam

Anton Gavazuk wrote:
> Did you put reference on you custom tiles config in web.xml? How you did that?
> 
> 2008/12/24 Adam Nichols <mr.adam.nichols@gmail.com>:
>> I'm using tiles 2.0.5 with myFaces.  I was able to get my application to
>> deploy, but when I got to my tiles page nothing inside <f:view> is output to
>> the browser.  When I made a sample page without tiles, it worked as
>> expected.  So I know JSF is set up properly.
>>
>> I deployed myfaces-example-tiles-1.1.8, and that worked fine.  I copied the
>> configuration settings and jsp pages into my tomcat project and nothing in
>> f:view renders there either..  Nothing helpful in the logs, even at debug
>> level.  What should I be looking at to find out what's going on?
>>
>> Thanks,
>> Adam
>>
> 

Mime
View raw message