tinkerpop-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF GitHub Bot (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (TINKERPOP-1864) Gremlin Python tests for GraphSON 2.0 and 3.0
Date Mon, 25 Jun 2018 16:11:00 GMT

    [ https://issues.apache.org/jira/browse/TINKERPOP-1864?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16522468#comment-16522468
] 

ASF GitHub Bot commented on TINKERPOP-1864:
-------------------------------------------

Github user spmallette commented on the issue:

    https://github.com/apache/tinkerpop/pull/883
  
    That's fair - changed now so that you get this if "graphson" isn't set:
    
    ```text
         [exec] Error: Hook 'prepare_traversal_source' from /home/smallette/git/apache/incubator-tinkerpop/gremlin-python/target/python2/radish/terrain.py:66
raised: 'ValueError: test configuration requires setting of --user-data="graphson=*" to one
of [v2,v3]'
         [exec] 
         [exec] Traceback (most recent call last):
         [exec]   File "/home/smallette/git/apache/incubator-tinkerpop/gremlin-python/target/python2/env/local/lib/python2.7/site-packages/radish/hookregistry.py",
line 121, in call
         [exec]     func(model, *args, **kwargs)
         [exec]   File "/home/smallette/git/apache/incubator-tinkerpop/gremlin-python/target/python2/radish/terrain.py",
line 70, in prepare_traversal_source
         [exec]     raise ValueError('test configuration requires setting of --user-data="graphson=*"
to one of [v2,v3]')
         [exec] ValueError: test configuration requires setting of --user-data="graphson=*"
to one of [v2,v3]
    ```
    
    also, if you don't have a good value for "graphson" then you get:
    
    ```text
         [exec] Error: Hook 'prepare_traversal_source' from /home/smallette/git/apache/incubator-tinkerpop/gremlin-python/target/python2/radish/terrain.py:66
raised: 'ValueError: serializer set with --user-data="graphson=v2" must be one of [v2,v3]'
         [exec] 
         [exec] Traceback (most recent call last):
         [exec]   File "/home/smallette/git/apache/incubator-tinkerpop/gremlin-python/target/python2/env/local/lib/python2.7/site-packages/radish/hookregistry.py",
line 121, in call
         [exec]     func(model, *args, **kwargs)
         [exec]   File "/home/smallette/git/apache/incubator-tinkerpop/gremlin-python/target/python2/radish/terrain.py",
line 77, in prepare_traversal_source
         [exec]     raise ValueError('serializer set with --user-data="graphson=v2" must be
one of [v2,v3]')
         [exec] ValueError: serializer set with --user-data="graphson=v2" must be one of [v2,v3]
    ```
    



> Gremlin Python tests for GraphSON 2.0 and 3.0
> ---------------------------------------------
>
>                 Key: TINKERPOP-1864
>                 URL: https://issues.apache.org/jira/browse/TINKERPOP-1864
>             Project: TinkerPop
>          Issue Type: Improvement
>          Components: python
>    Affects Versions: 3.3.1
>            Reporter: stephen mallette
>            Priority: Minor
>
> With TINKERPOP-1844 gremlin-python tests no longer run against GraphSON 2.0. They only
run against 3.0. It would be good to include runs against 2.0 as well - that will come with
some challenges because there are tests that simply can't run against 2.0 given its limitations.
To some degree, we do get some confidence that 2.0 still works as the 3.2.x tests still run
2.0 and will continue to do so.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message