tomcat-taglibs-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Maya Muchnik <mmuch...@pumatech.com>
Subject Re: unable to open tablibrary
Date Thu, 18 Jan 2001 18:23:12 GMT
I think, your TLD file must to be located under WEB-INF/taglib/testtags
directory, not WEB-INF/taglib directory. Maybe I am wrong.

Maya


"Yang,Chun" wrote:

> Hi, I have encountered the following error message when I try to run a jsp
> page with a simple empty bodycontent tag.
> The error message reads:
> org.apache.jasper.compiler.CompileException:
> D:\chun\testarea\taglib\helloworldtag.jsp(0,0) Unable to open taglibrary
> http://www.yangc.com/taglib/testtags : null
> The entries for the afore-mentioned taglib in web.xml is:
>     <taglib>
>         <taglib-uri>
>            http://www.yangc.com/taglib/testtags
>         </taglib-uri>
>         <taglib-location>
>            /WEB-INF/taglib/test-taglib.tld
>         </taglib-location>
>     </taglib>
> And the test-taglib.tld which is located in <CONTEXT_ROO>/WEB-INF/taglib has
> the following entry:
>   <tag>
>       <name>hw</name>
>       <tagclass>HelloWorldTag</tagclass>
>       <bodycontent>empty</bodycontent>
>       <info>
>       </info>
>   </tag>
> And the jsp page is as simple as
> <%@ taglib uri="http://www.yangc.com/taglib/testtags" prefix="foo" %>
> <html>
> <body>
>
> <foo:hw/>
>
> <hr>
>
> </body>
> </html>
>
> What could poooossibly be wrong ? I read the documentation several times and
> simply couldn't figure this out !
>
> btw, the environment I am working in is Apache1.3.14(win32) and TomCat3.2.1
>
> Your help is greatly appreciated!


Mime
View raw message