tomcat-taglibs-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ward, Jeff" <jw...@BenefitPoint.com>
Subject RE: error in request-examples.war(tld)
Date Wed, 14 Feb 2001 18:59:55 GMT
XML describes structure and location so it is possible the taglib directive
is correct but in the wrong place in the web.xml.  According to the DTD the
taglib element must come after a welcome-file element(if defined) but before
any resource-ref elements.
  This should be the order needed for all elements:

web-app
icon
small-icon
large-icon
display-name
description
distributable
context-param
param-name
param-value
servlet
servlet-name
servlet-class
jsp-file
init-param
load-on-startup
servlet-mapping
url-pattern
session-config
session-timeout
mime-mapping
extension
mime-type
welcome-file-list
welcome-file
taglib                    **********************
taglib-uri
taglib-location
error-page
error-code
exception-type
location
resource-ref
res-ref-name
res-type
res-auth
security-constraint
web-resource-collection
web-resource-name
http-method
user-data-constraint
transport-guarantee
auth-constraint
role-name
login-config
realm-name
form-login-config
form-login-page
form-error-page
auth-method
security-role
security-role-ref
role-link
env-entry
env-entry-name
env-entry-value
env-entry-type
ejb-ref
ejb-ref-name
ejb-ref-type
home
remote
ejb-link


 -----Original Message-----
From: 	Fickes, Vic [mailto:vic_fickes@exchange.prb.net] 
Sent:	Wednesday, February 14, 2001 10:30 AM
To:	taglibs-user@jakarta.apache.org
Subject:	error in request-examples.war(tld)

Hi,
In trying to deploy the request-examples web app, I get this error during
server startup (WLS5.1SP8):

Wed Feb 14 13:22:35 EST 2001:<E> <HTTP> Error parsing descriptor in Web
application '/web/Apache/jakarta-taglibs/request/request-examples.war'
org.xml.sax.SAXParseException: Element "web-app" does not allow "taglib"
here.

I looked at the taglib descriptor and it looks okay to me.  Is this a real
error, or did I do something wrong in my environment?
Thanks,
Vic

Mime
View raw message