tomcat-taglibs-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joachim Martin <jmar...@hbs.edu>
Subject Mailer: server attribute not used?
Date Wed, 05 Dec 2001 16:04:26 GMT
Hi,

After a couple frustrating hours, I finally got the mailer taglib to use a 
specified
smtp server by setting CATALINA_OPTS to -Dmail.smtp.host=smtp.hbs.edu.

I tried using the server="smtp.hbs.edu" attribute, but it didn't work.  I 
tried hardcoding
my smtp server in MailTag.java and then in SentTag.java, but that didn't work.
(I actually don't see where the server attribute is ever being used).

I then tried numerous combinations of <param> type configs in various xml 
files, to
no avail (I admit to being a tomcat novice).

Setting an environment variable on the command line is ok, but I'm 
wondering why
the server attribute isn't working for me.  After doing some debugging, it 
looks like 1)
the server attribute is never used to set up the "mail.smtp.host" property 
for the Session
object, and 2) the sessionobj (in MailTag) that is passed to new 
MimeMessage() is null.

Am I crazy?  Is this working for everyone else?  Or am I the only one not 
using a local
SMTP server?  I'm guessing that the JavaMail API is involved here.

This is on Solaris 5.6, JDK 1.3.1, Tomcat 4.0-B1.  Does anyone know of a 
way to put
this system property in a server.xml or web.xml file so I don't have to 
modify the
environment or the startup script?

Thanks --Joachim


--
To unsubscribe, e-mail:   <mailto:taglibs-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:taglibs-user-help@jakarta.apache.org>


Mime
View raw message