tomcat-taglibs-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kerekes Lajos <ya...@freemail.hu>
Subject Error in using JSTL 1.0
Date Sat, 21 Dec 2002 15:54:49 GMT
Hello!

I am a newbie. I have downloaded the JSTL 1.0, and copied the JAR files
into the
web-inf/lib directory of my application. I use Apache Tomcat/4.1.12
under
Windows 98.
If I want to use the taglib directory
<%@ taglib uri="http://java.sun.com/jstl/core" prefix="c" %>
than I get the following error:
----------
type Exception report

message

description The server encountered an internal error () that prevented
it from fulfilling this request.

exception

org.apache.jasper.JasperException: null(-1,-1) This absolute uri
(http://java.sun.com/jstl/core) cannot be resolved in either web.xml or
the jar files deployed with this application
        at
org.apache.jasper.compiler.DefaultErrorHandler.jspError(DefaultErrorHandler.java:94)

        at
org.apache.jasper.compiler.ErrorDispatcher.dispatch(ErrorDispatcher.java:417)

        at
org.apache.jasper.compiler.ErrorDispatcher.jspError(ErrorDispatcher.java:154)

        at
org.apache.jasper.compiler.TagLibraryInfoImpl.(TagLibraryInfoImpl.java:159)

        at
org.apache.jasper.compiler.Parser.parseTaglibDirective(Parser.java:354)
.
.
.
.
-------------
After it I tried to use the application under standard-examples.war, but
if the code
contains <%@ taglib....> I get same error page.
First I thought the problem is, that I am offline, but I get same
message when I'm online too.
What can be the problem?

   Thank you in advanced:

    Lajos Kerekes



--
To unsubscribe, e-mail:   <mailto:taglibs-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:taglibs-user-help@jakarta.apache.org>


Mime
View raw message